DELPHI盒子
!实时搜索: 盒子论坛 | 注册用户 | 修改信息 | 退出
检举帖 | 全文检索 | 关闭广告 | 捐赠
技术论坛
 用户名
 密  码
自动登陆(30天有效)
忘了密码
≡技术区≡
DELPHI技术
移动应用开发
Web应用开发
数据库专区
报表专区
网络通讯
开源项目
论坛精华贴
≡发布区≡
发布代码
发布控件
文档资料
经典工具
≡事务区≡
网站意见
盒子之家
招聘应聘
信息交换
论坛信息
最新加入: sql2003s
今日帖子: 1
在线用户: 3
导航: 论坛 -> DELPHI技术 斑竹:liumazi,sephil  
作者:
男 niecn (niecn) ★☆☆☆☆ -
注册会员
2022/9/29 18:09:16
标题:
AutoUpgrader组件在最新版Delphi 11.2中win64编译执行无效(出现致命错误) 浏览:646
加入我的收藏
楼主: Delphi 11及之前AutoUpgrader组件不会存在任何问题,Delphi 11.2版本AutoUpgrader只要编译成win64,执行无法正常发现新版本,debug情况下自动检查新版本时出现致命错误,Win32编译的执行起来没有问题。与操作系统版本没有关系,应该又是组件本身移植64位问题。
自从Delphi 11.1开始,64位编译器开始严格了,哪位高手看看问题出在何处,如果能帮忙修改一个11.2能用的AutoUpgrader,不胜感激。
----------------------------------------------
-
作者:
男 vmao (毛小毛) ★☆☆☆☆ -
盒子活跃会员
2022/9/30 8:29:33
1楼: 改好了发我一份,谢谢
----------------------------------------------
-
作者:
男 sail2000 (小帆工作室) ★☆☆☆☆ -
盒子活跃会员
2022/9/30 11:15:21
2楼: 有几段加密解密的 ASM 代码在 x64 上编译不了,需要会汇编的高手才行。或者能用 Pascal 代码取代这些 ASM 也行。
----------------------------------------------
delphi 是兴趣,和工作无关,即使它倒闭。
又不靠它 delphi 吃饭,怕甚?
作者:
男 niecn (niecn) ★☆☆☆☆ -
注册会员
2022/9/30 12:18:15
3楼: 应该不是asm代码的问题,平时我使用时都是把asm注释了,64位编译也可顺利通过,编译一直没有问题,问题是执行时无法发现新版本,应该是64位移植的问题。
----------------------------------------------
-
作者:
男 maidashu (麦大叔) ▲△△△△ -
注册会员
2022/10/3 13:07:15
4楼: 有支持delphi10.4的版本没?谢谢!
----------------------------------------------
-
作者:
男 xlonger (xlonger) ★☆☆☆☆ -
普通会员
2022/10/5 19:44:14
5楼: 楼主 有没有明白 这个组件的工作流程和原理呢?我感觉自己写个类似的,功能的简单更新组件 也可以啊。我大概2008也用过这个组件,后来看了一下组件的自动升级原理和一些关键代码,自己扣出一些代码,整合到自己软件里,也能自动更新了啊。
----------------------------------------------
我打的是酱油,而不是别的什么油。
我灌的是口水,而不是别的什么水。
我聊的折腾不是那个不折腾的折腾。
我说的阿娇不是那个邓玉娇的阿娇。
3个代表,6个为什么,9个肠胃炎。
D性强的领导干部都不喜欢热比娅。
我特别要讲的是,屁民网黄色论坛是我经常上网必选的 网站之一
作者:
男 letianwuji (大器晚成) ▲▲▲▲△ -
注册会员
2022/10/5 19:45:39
6楼: 执行时无法发现新版本??我咋听着是没获取到数据包。
----------------------------------------------
相信自己,若自己都不相信,那还有谁可信。
信息
登陆以后才能回复
Copyright © 2CCC.Com 盒子论坛 v2.1 版权所有 页面执行11.71875毫秒 RSS